Investigating an issue with Venmo Support phone system
Incident Report for Venmo
Resolved
This incident has been resolved.
Posted 9 months ago. Jan 18, 2017 - 18:38 EST
Investigating
We are investigating issues with inbound calling to the Venmo Support; Inbound calls may fail or ring without answer. Support remains available via email at support@venmo.com or chat via the Venmo app.

There is no effect to production systems or transaction processing.
Posted 9 months ago. Jan 18, 2017 - 12:21 EST