Connectivity Issues
Incident Report for Venmo
Resolved
The issue has been resolved.
Posted over 1 year ago. Dec 17, 2015 - 17:19 EST
Investigating
We are currently investigating sporadic connection problems to Venmo services.
Posted over 1 year ago. Dec 17, 2015 - 17:08 EST