Venmo Telephone Support Issue
Incident Report for Venmo
Resolved
Phone service has been restored.
Posted about 1 year ago. Jun 01, 2016 - 13:04 EDT
Investigating
We are investigating issues with inbound calling to the Venmo Support telephone number. Support remains available via Chat in the Venmo App or via email at support@venmo.com.
Posted about 1 year ago. Jun 01, 2016 - 12:44 EDT