Notification Delays
Incident Report for Venmo
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 15, 2016 - 14:33 EST
Identified
We're experiencing a slight delay in notifications (Email, SMS, Mobile) and are working to resolve at this time.
Posted almost 2 years ago. Jan 15, 2016 - 13:26 EST