Web site and some app screens are not working correctly
Incident Report for Venmo
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jan 20, 2017 - 15:07 EST
Identified
The Venmo website is currently experiencing some difficulty. Users may have trouble using the website and logging into their accounts from mobile devices.
Posted almost 2 years ago. Jan 20, 2017 - 14:30 EST