Signup Issues
Incident Report for Venmo
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 21, 2016 - 22:37 EDT
Monitoring
The signup issue should be resolved. We are monitoring signups to confirm this is the case.
Posted over 1 year ago. Mar 21, 2016 - 22:01 EDT
Identified
Some people are reporting issues when signing up for new accounts. We have identified the problem and it will be corrected shortly.
Posted over 1 year ago. Mar 21, 2016 - 21:20 EDT