Search Performance Degradation
Incident Report for Venmo
Resolved
We have resolved the issue.
Posted over 2 years ago. Apr 13, 2015 - 20:11 EDT
Identified
We are working to resolve a performance degradation in user searches.
Posted over 2 years ago. Apr 13, 2015 - 19:05 EDT