Notification Delays
Incident Report for Venmo
Resolved
An issue with an upstream provider has been resolved, notifications are no longer being delayed.
Posted almost 2 years ago. Nov 17, 2015 - 23:21 EST
Identified
We're experiencing a slight delay in notifications (Email, SMS, Mobile) and are working to resolve at this time.
Posted almost 2 years ago. Nov 17, 2015 - 22:33 EST