Search Performance Issue
Incident Report for Venmo
Resolved
This incident has been resolved.
Posted over 2 years ago. May 21, 2015 - 17:15 EDT
Identified
Some user searches may run slowly at this time, we are working on resolution
Posted over 2 years ago. May 21, 2015 - 16:07 EDT