Performance Degradation
Incident Report for Venmo
Resolved
Performance is back to normal at this time.
Posted over 2 years ago. Apr 08, 2015 - 12:16 EDT
Investigating
We're currently investigating a performance degradation affecting logins.
Posted over 2 years ago. Apr 08, 2015 - 11:50 EDT