Notification delay
Incident Report for Venmo
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jul 03, 2015 - 00:30 EDT
Monitoring
We've deployed a fix to resolve these delays and are monitoring at this time
Posted almost 2 years ago. Jul 02, 2015 - 23:16 EDT
Identified
We have identified a delay in notifications and are working on resolution
Posted almost 2 years ago. Jul 02, 2015 - 22:54 EDT